PHP, which is a bacronym for PHP: Hypertext Preprocessor, is amongst the most commonly used general-purpose web programming languages available out there. Any site or Internet application based on PHP will run on a given web server provided that a PHP module is enabled, which makes the language really universal and it is little surprising that there are a couple of million servers that support it and 100s of millions of PHP-driven sites running on them. PHP is preferred over HTML because it enables you to set up a dynamic site with heaps of options. A PHP-based social network, for instance, will show different web content to each user in spite of the fact that the URL will remain unchanged. In comparison, HTML websites are static and the content on the pages can be updated only manually. Like any other software, PHP has several versions and the version that was used while developing a specific website must be available on the server in order for the site to work faultlessly.
PHP 4 and PHP 5 Support in Website Hosting
With our website hosting, you will be able to select the PHP version that will be enabled for your shared hosting account, since multiple versions are installed on our servers. With just one click of the mouse, you’ll be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and each time a new version is unveiled in the future, we’ll add it to the Hepsia hosting Control Panel without removing the previous versions. Thus, you will be able to host all the websites that you’ve set up throughout the years. In contrast to lots of other web hosts, we will not force you to update such sites, because a script may be out of date, but this doesn’t mean that it’s insecure as you may have performed modifications to its code to fill safety loopholes. For the sake of your convenience, you’ll even be able to set a different PHP version for each site hosted in your shared account.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Even in case your websites were created with an older PHP version, you’ll be able to host them in a semi-dedicated server account from us, as we support multiple versions running at the same time on our servers and each of them can be enabled for your account with no more than one click of the mouse through our in-house created Hepsia hosting Control Panel. In addition to the most recent PHP 5.4 and PHP 5.5, we also offer 5.2, 5.3 and the older PHP 4. The latter has already been dropped by the vast majority of hosting suppliers, but we feel that you should not be forced to modify a website that took years to develop, as older script language syntax does not necessarily equal safety flaws. Just the opposite, a correctly maintained site using PHP 4 can be more secure than an inadequately maintained one using PHP 5. For your convenience, we will also give you the opportunity to pick a different PHP version for each website within your account.